Cloudflare System Status

Network Performance Issues in Zurich

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Sep 09, 2023 - 15:27 UTC

Update

We are continuing to investigate this issue.
Posted Sep 09, 2023 - 14:52 UTC

Investigating

Cloudflare is investigating issues with network performance in Zurich, Switzerland (ZRH).
Posted Sep 09, 2023 - 14:51 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).