Cloudflare System Status

SSL Certificate Provisioning Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 21, 2026 - 14:01 UTC

Investigating

Cloudflare is investigating multiple reports of advanced certificate issuance delays
Posted Jun 21, 2026 - 13:46 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).