Cloudflare System Status

DNS Update delays
Incident Report for Cloudflare
Resolved
This incident has been resolved and DNS updates have returned to normal.
Posted about 1 month ago. Aug 21, 2019 - 16:28 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted about 1 month ago. Aug 21, 2019 - 16:18 UTC
Investigating
Cloudflare is investigating delays of over 50 minutes in updates to DNS records. This delay also affects provisioning new Argo Tunnel instances by over 50 minutes.

DNS resolution and established Argo Tunnels are not impacted.
Posted about 1 month ago. Aug 21, 2019 - 15:44 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).