Cloudflare System Status

Digital Experience in Cloudflare Zero Trust Latency

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 19, 2026 - 15:57 UTC

Investigating

Actions related to Digital Experience are delayed, Cloudflare is aware and investigating.
Posted May 19, 2026 - 15:25 UTC
This incident affected: Cloudflare Sites and Services (Digital Experience Monitoring (DEX), Zero Trust).