Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 11 days ago. Jun 05, 2019 - 00:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 days ago. Jun 04, 2019 - 21:19 UTC
Update
We are continuing to investigate this issue.
Posted 11 days ago. Jun 04, 2019 - 21:05 UTC
Investigating
Cloudflare is experiencing problems in processing changes through our billing subscription service. Configuration changes that involve billing are currently affected including upgrading and downgrading subscriptions.

CDN and requests through Cloudflare are not currently affected.

We will provide an update once billing subscription services return to normal.
Posted 11 days ago. Jun 04, 2019 - 21:04 UTC
This incident affected: Cloudflare Sites and Services (Billing).