Cloudflare System Status

Increased build dequeue duration in Workers Builds

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 04, 2026 - 22:01 UTC

Investigating

Some Workers Builds users may experience increased build dequeue times, or builds that are stuck in a queued state indefinitely.
Posted May 04, 2026 - 20:20 UTC
This incident affected: Cloudflare Sites and Services (Workers Builds).