Cloudflare System Status

Customers may see incorrect invoice payment status

Incident Report for Cloudflare

Identified

We have identified an additional path that leads to users not seeing the correctly reflected payment state on invoices and are working on a fix.
Posted Jun 17, 2026 - 00:52 UTC

Investigating

We are currently investigating this issue.
Posted Jun 16, 2026 - 22:51 UTC

Identified

Customers may not see invoice payment status accurately reflected in the Cloudflare UI for payments made since June 11.

Impacted customers will see paid Invoices shown as Unpaid via the Cloudflare Dashboard.
Posted Jun 16, 2026 - 15:53 UTC
This incident affects: Cloudflare Sites and Services (Billing, Dashboard).