Cloudflare System Status

DNS delay in Cairo
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 06, 2016 - 13:18 UTC
Investigating
We are investigating DNS delay in Cairo
Posted Jun 03, 2016 - 04:25 UTC