A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 03:47 UTC
Investigating
Cloudflare is observing network performance issues in Miami. We are actively working to reduce or eliminate any impact to Internet users in this locations.
Posted Apr 24, 2026 - 03:46 UTC
This incident affected: Cloudflare Sites and Services (Network).