Cloudflare System Status

Increased latency with cloudflare-dns.com

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 15:27 UTC

Investigating

Cloudflare is aware of, and investigating, an increased latency on cloudflare-dns.com.

Further detail will be provided as more information becomes available.
Posted Aug 25, 2025 - 14:19 UTC