Cloudflare System Status

Issues with R2 S3 Endpoint

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 19:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 23, 2025 - 17:52 UTC

Investigating

R2 S3 Endpoint Inaccessible for Accounts Created Between 13:00–18:20 UTC on July 22, 2025
Posted Jul 23, 2025 - 17:29 UTC
This incident affected: Cloudflare Sites and Services (R2).