Cloudflare System Status

Access for SaaS applications failing to authenticate

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 02:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 02:12 UTC

Identified

Cloudflare engineering is working on reverting the affected signing keys. We do not advise updating keys if you are impacted.
Posted Jun 18, 2025 - 23:29 UTC

Investigating

Cloudflare engineering is investigating an issue causing authentication to fail for some Access for SaaS applications. This is due to an incorrect certificate signing key. The engineering team is investigating a solution to revert to the original keys.

Access self-hosted and private network application authentication is not impacted at this time.
Posted Jun 18, 2025 - 23:17 UTC
This incident affected: Cloudflare Sites and Services (Access).