Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 08, 2015 - 20:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2015 - 18:43 UTC
Identified
Further congestion identified in Frankfurt, working to mitigate.
Posted Mar 08, 2015 - 18:23 UTC
Monitoring
We've Identified some network congestion affecting Dallas and Newark data centers, fix in place and monitoring.
Posted Mar 08, 2015 - 18:02 UTC