Cloudflare System Status

R2 and Durable Objects increased errors in Eastern North America

Incident Report for Cloudflare

Monitoring

The increase in errors are resolved and the services are stable again.

Customers using Queues, Cache Reserve and Cache Purge API may have also been impacted.
Posted May 16, 2026 - 02:27 UTC

Update

Customers may also see impact with Worker uploads with R2 bindings and when creating Workflow instances.
Posted May 16, 2026 - 02:07 UTC

Investigating

Cloudflare is aware of and investigating an increase of R2 and Durable Object errors in Eastern North America. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted May 16, 2026 - 01:55 UTC
This incident affects: Cloudflare Sites and Services (Durable Objects, R2, Workflows).