Cloudflare System Status

Workers section in Cloudflare Dash may be crashing for some users

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Aug 19, 2025 - 22:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 19:34 UTC

Identified

The Workers section in Cloudflare Dash may be crashing for some users. We've identified the issue and are working on a fix at the moment.
Posted Aug 19, 2025 - 16:52 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).