We have identified the root cause and reverted the impacted change. However, for the fix to apply to existing Workers utilizing Gradual Deployments, affected Workers must have their deployment traffic percentages adjusted or redeployed.
As a workaround, if you are currently impacted, you can immediately resolve the issue for your service by modifying the traffic weights of your Gradual Deployment (for example, shifting your active deployment weights from 50%/50% to 40%/60%, or redeploying your Worker).
We are actively working on an automated fix for all remaining affected customers and will provide another update once resolved.
Posted Aug 07, 2026 - 17:10 UTC
Investigating
Cloudflare is aware, and investigating reports where a subset of customers are not seeing logs in the Workers Observability dashboard after deploying a new version of a Worker. Affected Workers continue to run and serve traffic normally. Metrics remain available.
Posted Aug 07, 2026 - 16:04 UTC
This incident affected: Cloudflare Sites and Services (Workers Observability).