Cloudflare System Status

Customer Impacting Issue with SZX
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 14:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2021 - 14:50 UTC
Investigating
Cloudflare is aware of, and investigating issues with SZX in Dongguan China. Further detail will be provided as more information becomes available.
Posted Apr 20, 2021 - 13:37 UTC
This incident affected: Asia (Dongguan, China - (SZX)).