Cloudflare System Status

Network Congestion

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 20:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 17, 2025 - 20:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 17, 2025 - 20:23 UTC

Investigating

Cloudflare is observing possible network congestion in the western North America. We are working to mitigate impact to Internet users in this region. Stream users may see elevated error rates in delivery and upload paths. Video upload or viewing requests may need to be retried due to server side errors.
Posted Dec 17, 2025 - 19:55 UTC
This incident affected: North America (Calgary, AB, Canada - (YYC), Dallas, TX, United States - (DFW), Denver, CO, United States - (DEN), Honolulu, HI, United States - (HNL), Las Vegas, NV, United States - (LAS), Los Angeles, CA, United States - (LAX), Mexico City, Mexico - (MEX), Portland, OR, United States - (PDX), Queretaro, MX, Mexico - (QRO), Sacramento, CA, United States - (SMF), Salt Lake City, UT, United States - (SLC), San Diego, CA, United States - (SAN), San Jose, CA, United States - (SJC), Saskatoon, SK, Canada - (YXE), Seattle, WA, United States - (SEA), St. Louis, MO, United States - (STL), Vancouver, BC, Canada - (YVR), San Francisco, United States - (SFO), Austin, United States - (AUS), Albuquerque, United States - (ABQ), Guadalajara, Mexico - (GDL), San Antonio, United States - (SAT), Oklahoma City, United States - (OKC), Anchorage, United States - (ANC)) and Cloudflare Sites and Services (R2, Stream).