Last updated: Fetched just now
Interstitial page bypass failing
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Investigating
Some site visitors are prompted for a flagged phishing site and are unable to accept and continue, we are investigating the issue