Cloudflare System Status

Domain registration and renewal issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 21:51 UTC
Monitoring
Cloudflare has identified and corrected an issue that disrupted the registration of new domains. We are monitoring the results.
Posted Feb 06, 2024 - 21:44 UTC
This incident affected: Cloudflare Sites and Services (Registrar).