Cloudflare System Status

Customer Impacting Issue - Speed testing tool not working reliably
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 22:48 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Nov 03, 2021 - 22:23 UTC
Investigating
Cloudflare is aware of and investigating an issue that causes disruptions in our speed testing tool. Further details will be provided as more information becomes available
Posted Nov 03, 2021 - 21:52 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).