Cloudflare System Status

Intermittent Challenge page issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 18:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 11, 2026 - 18:01 UTC

Investigating

Some customers may find challenge pages may be impossible to solve.
Posted Mar 11, 2026 - 17:35 UTC
This incident affected: Cloudflare Sites and Services (Bot Management, Challenge Platform).