Cloudflare System Status

Increase in 502 errors

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 23:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 23:40 UTC

Identified

Cloudflare is aware of reports and has identified an issue causing an increase of 502 errors for a subset of customers. A fix is being implemented
Posted Mar 26, 2026 - 23:30 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).