Cloudflare System Status

Purge delays for Durable Objects in Western Europe

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 13:08 UTC

Update

We are continuing to investigate this issue.
Posted Nov 27, 2025 - 11:34 UTC

Investigating

Cloudflare is aware of, and investigating an issue with Durable Objects which potentially impacts multiple customers in Western Europe. Durable Objects cache single flex purges are experiencing delays in the aforementioned regions. We are currently investigating this issue.
Posted Nov 27, 2025 - 11:12 UTC
This incident affected: Cloudflare Sites and Services (Durable Objects).