Cloudflare System Status

Issue accessing the Cloudflare IP ranges page

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 12, 2026 - 21:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 20:23 UTC

Investigating

Cloudflare is investigating an issue with https://www.cloudflare.com/ips-v4. Customers attempting to view the published list of Cloudflare IPv4 ranges may receive an HTTP 500 error. This issue is limited to the IP-ranges page on www.cloudflare.com and does not affect Cloudflare's CDN, DNS, security, or any other production services. We are working to mitigate this problem
Posted May 12, 2026 - 19:57 UTC
This incident affected: Cloudflare Sites and Services (Marketing Site).