Cloudflare System Status

DNS Update Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 08, 2023 - 10:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2023 - 10:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 08, 2023 - 09:53 UTC

Investigating

Cloudflare is investigating delays in propagation of updates to DNS records for some free plan websites. More updates to follow shortly.
Posted Jun 08, 2023 - 09:35 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).