Cloudflare System Status

Page Rule Propagation Delay

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 29, 2021 - 19:25 UTC

Monitoring

A fix has implemented a fix and we are monitoring the results.
Posted Apr 29, 2021 - 18:00 UTC

Investigating

Cloudflare's Page Rules API is experiencing issues where rules propagation to the Edge are delayed. This only affects Page Rule updates and creation of new page rules.

Existing Cloudflare Page Rules already in production remain unaffected and are operating normally.
Posted Apr 29, 2021 - 17:40 UTC