Cloudflare System Status

Workers Update Delays and Cloudflare Pages Deployment Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 24, 2022 - 14:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2022 - 14:21 UTC
Investigating
Cloudflare is experiencing delays in updating Workers on the edge and executing new Cloudflare Pages deployments. This does not impact existing Workers and Pages projects already deployed in production.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted May 24, 2022 - 13:48 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Workers, Cloudflare Pages).