Cloudflare System Status

Unable to access Settings Page for Cloudflare Pages Projects

Incident Report for Cloudflare

Resolved

We have determined this did not have user impact.
Posted Feb 24, 2026 - 23:20 UTC

Investigating

Cloudflare is aware of and investigating an issue where users are unable to access the settings page for Cloudflare Pages Projects, particularly when no repository is connected. We are working to analyze and resolve this problem. More updates to follow shortly.
Posted Feb 24, 2026 - 23:08 UTC
This incident affected: Cloudflare Sites and Services (Pages).