Cloudflare System Status

Elevated latency uploading Workers Static Assets

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 18:47 UTC

Investigating

Cloudflare is investigating elevated latency uploading Workers Static Assets. Workers scripts which are already uploaded are not impacted.
Posted Apr 02, 2026 - 17:39 UTC
This incident affected: Cloudflare Sites and Services (Workers Assets).