Cloudflare System Status

Cloudflare WAF: Issues with Duplicate Rate Limiting Rules

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 17:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2025 - 11:30 UTC

Investigating

Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers: zones that have migrated from our former Rate Limiting rules might observe duplicated rules. This means that in some cases, expected rate limiting rules are not taking effect. This impacts only customers that use rate limits based on response codes.

We are working to resolve the issue. More updates to follow shortly.
Posted Nov 07, 2025 - 10:59 UTC
This incident affected: Cloudflare Sites and Services (Firewall).