Cloudflare System Status

Cloudflare Email Routing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Aug 23, 2022 - 10:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2022 - 09:37 UTC
Investigating
Cloudflare is investigating issues with Email Routing product. Some emails might be temporarily bounced back to the sender.

Impact is restricted to email forwarding functionality and it does not affect any connectivity, security, CDN or Area1 functionality.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Aug 23, 2022 - 09:34 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).