Cloudflare System Status

Spectrum Connectivity issues and Email Routing delivery delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 23:17 UTC
Update
Email Routing may also be affected. Customer may experience mail delivery delays.
Posted Apr 28, 2022 - 23:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2022 - 23:00 UTC
Investigating
Spectrum is experiencing issues in KUL, LIS, BLR and YYZ data centers. Issue has been identified and fix is being rolled out. Customers may experience issues when accessing applications behind Spectrum.
Posted Apr 28, 2022 - 23:00 UTC
This incident affected: Asia (Bangalore, India - (BLR), Kuala Lumpur, Malaysia - (KUL)), Cloudflare Sites and Services (Cloudflare Spectrum), Europe (Lisbon, Portugal - (LIS)), and North America (Toronto, ON, Canada - (YYZ)).