Cloudflare System Status

Email Delivery Delays

Incident Report for Cloudflare

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 16:29 UTC

Investigating

Cloudflare is investigating a delay in our ability to send emails. This does not affect our support platform communication capabilities.
We are working to resolve the issue with our email provider, more updates to follow shortly.
Posted Nov 04, 2025 - 10:16 UTC
This incident affects: Cloudflare Sites and Services (Notifications).