Cloudflare System Status

Network Performance Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 30, 2024 - 17:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 30, 2024 - 17:03 UTC
Investigating
Cloudflare is investigating issues with Network Performance.

Impacted traffic included traffic between Europe and Asia Pacific, as well as between Asia Pacific and Central/East Coast of North America.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted May 30, 2024 - 12:49 UTC
This incident affected: Cloudflare Sites and Services (Network).