Cloudflare System Status

Email Routing Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 24, 2022 - 14:10 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 24, 2022 - 13:51 UTC

Investigating

Cloudflare customers using Email Routing may experience issues making changes to current configuration. Email delivery is not affected. Further detail will be provided as more information becomes available.
Posted Mar 24, 2022 - 13:38 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).