Cloudflare System Status

Network Analytics Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted May 19, 2020 - 15:44 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted May 19, 2020 - 14:04 UTC
Investigating
We are investigating a potential issue with data visibility within Network Analytics that may be affecting some customers.

This does not impact upon other dashboard or production traffic.
Posted May 19, 2020 - 13:23 UTC
This incident affected: Cloudflare Sites and Services (Analytics).