Cloudflare System Status

Cloudflare configuration changes and alerts delayed
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 14:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2022 - 13:46 UTC
Update
Cloudflare is still investigating delays regarding email routing.
We earlier saw delays in configuration changes and alerts for other services, which has since been resolved.
Edge traffic forwarding is unaffected. More updates to follow shortly.
Posted Apr 22, 2022 - 13:21 UTC
Update
Cloudflare is currently investigating delays regarding email routing.
We earlier saw delays in configuration changes and alerts for other services, which has since been resolved.
Edge traffic forwarding is unaffected. More updates to follow shortly.
Posted Apr 22, 2022 - 13:08 UTC
Identified
Cloudflare is investigating delays regarding updates to configuration changes and alerts.

Edge traffic forwarding is unaffected. More updates to follow shortly.
Posted Apr 22, 2022 - 12:01 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).