Cloudflare System Status

Possible Network Routing issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 13:42 UTC
Investigating
Cloudflare is observing possible network routing issues in some regions.

We are currently working to mitigate impact.
Posted Feb 28, 2024 - 12:51 UTC
This incident affected: Cloudflare Sites and Services (Network).