Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted 3 months ago. Aug 06, 2019 - 23:22 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

If you are still noticing errors when trying to add a payment method, please clear your browser cache and try again.

We will update the status once the issue is resolved.
Posted 3 months ago. Aug 06, 2019 - 22:32 UTC
Investigating
Cloudflare is experiencing a problem allowing credit cards to be added/updated in the dashboard. The cause is being investigated. This problem does not impact currently active subscriptions or service.
Posted 3 months ago. Aug 06, 2019 - 22:02 UTC
This incident affected: Cloudflare Sites and Services (Billing).