Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and DNS updates have resumed normal operation.
Posted Oct 16, 2019 - 14:58 UTC
Update
We are continuing to work on a fix for this issue. Cloudflare is still seeing delays of up to two hours for updates to DNS records.
Posted Oct 16, 2019 - 14:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2019 - 12:54 UTC
Investigating
Cloudflare is investigating delays of up to one hour for updates to DNS records. This delay also affects provisioning SSL certificates and new Argo Tunnel instances.

DNS resolution, existing SSL certificates, and established Argo Tunnels are not impacted.
Posted Oct 16, 2019 - 12:21 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).