Cloudflare System Status

Apps Marketplace degraded
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 20:26 UTC
Update
Cloudflare is continuing to investigate issues with the Apps Marketplace.

Installing, editing or removing an app will take more than 60 seconds.

Issues with previewing apps have been fixed.
Posted Aug 31, 2020 - 19:47 UTC
Update
Cloudflare is continuing to investigate issues with the Apps Marketplace.

Installing, editing or removing an app will take more than 60 seconds.

Issues with previewing apps have been fixed.
Posted Aug 31, 2020 - 18:42 UTC
Investigating
Cloudflare is currently investigating issues with the Apps Marketplace. Customers may be unable to preview Apps, and installing, editing or removing an app will take more than 60 seconds.
Posted Aug 31, 2020 - 17:24 UTC
This incident affected: Cloudflare Sites and Services (Apps Marketplace).