Cloudflare System Status

Cloudflare Dashboard Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 12, 2023 - 18:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 18:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2023 - 18:19 UTC
Investigating
Cloudflare is investigating issues with some customers managing domain registration with the Cloudflare Dashboard.
More updates to follow.
Posted May 12, 2023 - 18:07 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).