Cloudflare System Status

Increased Latency for Durable Objects in Eastern North-America

Incident Report for Cloudflare

Resolved

An effective fix was implemented and this incident is now resolved.
Posted Aug 06, 2025 - 21:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2025 - 15:08 UTC

Investigating

Cloudflare is aware of, and investigating an issue with Durable Objects which potentially impacts multiple customers in the Eastern North-American region. Durable Objects are experiencing an increase in latency on purge actions in the aforementioned region. We are currently investigating this issue.
Posted Aug 06, 2025 - 14:20 UTC
This incident affected: Cloudflare Sites and Services (Durable Objects).