Cloudflare System Status

Cloudflare Notifications issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 29, 2026 - 07:32 UTC

Monitoring

Cloudflare is investigating issues with the Cloudflare Notifications product. Some alerts might be temporarily delayed.

Impact is restricted to the notification functionality and it does not affect any connectivity, security, CDN or Area1 functionality.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted May 29, 2026 - 07:32 UTC
This incident affected: Cloudflare Sites and Services (Notifications).