A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 14:49 UTC
Investigating
Cloudflare is investigating issues when interacting with Workers API and Workers configuration in the dashboard. Customers might experience unexpected errors on Workers endpoints, particularly when deploying a script. Workers that are already running in production are not affected. More updates to follow shortly.
Posted Jul 17, 2026 - 14:34 UTC
This incident affected: Cloudflare Sites and Services (Workers).