Cloudflare System Status

Delays in custom hostname activations
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 20, 2023 - 19:46 UTC
Update
We are continuing to investigate this issue.
Posted Apr 20, 2023 - 18:56 UTC
Investigating
Cloudflare is investigating delays in custom hostname activations.

Custom hostnames already in production remain unaffected and are operating normally.
Posted Apr 20, 2023 - 18:06 UTC
This incident affected: Cloudflare Sites and Services (R2, Stream, SSL for SaaS Provisioning).