A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 01:56 UTC
Investigating
Cloudflare is investigating issues with Network Performance in London. Some customers may experience increased latency or timeouts for the uksouth Azure region.
We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Jul 08, 2026 - 01:56 UTC
This incident affected: Europe (London, United Kingdom - (LHR)) and Cloudflare Sites and Services (Network).