Cloudflare System Status

IP Geolocation Inaccuracies
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 21:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2021 - 18:35 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2021 - 17:32 UTC
Investigating
Customers may notice inaccuracies in IP geolocation data. Issue has been identified and mitigation is in progress.
Posted Apr 28, 2021 - 17:14 UTC