Cloudflare System Status

Cloudflare Images: Upload issues

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted May 29, 2025 - 16:58 UTC

Monitoring

We were able to identify the cause of this issue and implement a fix. We are currently monitoring the results.
Posted May 29, 2025 - 16:42 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2025 - 16:02 UTC

Investigating

Cloudflare is aware of, and investigating an issue with our Images feature: customers may observe errors or delays when attempting to upload images onto upload.imagedelivery.net
Further detail will be provided as more information becomes available.
Posted May 29, 2025 - 14:28 UTC
This incident affected: Cloudflare Sites and Services (Images).